Origin 2022b Bug Fixes

Origin 2022b Bug Fixes

Graphing

JIRA

SUMMARY

DETAILS

JIRA

SUMMARY

DETAILS

ORG-24505

Insert: Plot to Layer broken after open Layer Management

New a graph and open Layer Management, close it, click Insert: Plot to Layer

==> Fails to show context menu

Fixed in Origin 2022b

ORG-24472

Refresh issue when scaling factor combo is shown after change line width

Open Plot Detail with Line plot, set line width as column

==> Fill Area Under Curve mess up

Fixed in Origin 2022b

ORG-24476

Tick type of axis break is changed after change Y axis tick type even if auto ascale is unchecked

  1. Set Axis major ticks to Custom Postion.

  2. Enable Axis Break. Uncheck auto scale in Axis Break dialog.

  3. Change axis major tick label to by count and click OK.

==>Major tick after break is changed

ORG-24267

Reverse Plot Order of Parallel Plot should exchange axis

  1. new worksheet, import body.dat from exe folder\Samples\Statistics

  2. select all and plot parallel plot → note 1st and 3rd data is categorical data

select layer level in OM, right click and select reverse plot order

==> there is no label in 1st axis, and last axis could not show proper categorical label. We should exchange axis when reverse plot.

Fixed in Orign 2022b.

ORG-24661

German Origin crash when mousing over User-defined symbol area of Graph tab in Preferences: Options dialog

This is a German only crash in Origin 2022.

Fixed in Orign2022b.

Choose Preferences: Options menu.

Go to Graph tab.

Mouse over the big User-defined Symbols box.

==> Crash.

Workaround: Set Help: Change Language to change Origin to English to create user-defined symbols. Then switch language back to German to use the created symbols.

Or copy image to clipboard and choose the user-defined symbol on clipboard in Plot Details dialog.

As long as you don’t mouse over the control in Options dialog in German Origin, it’s fine.

ORG-24591

Fails to keep Offset setting in Grid Settings dialog

  1. In graph window, click edge of the graph and show page mini toolbar,

  2. Click Show Grid button, click Page Grid Settings, Set Offset

==> Fails to keep Offset setting after restart Origin

Fixed in Origin 2022b

ORG-23710

Enable anti-aliasing will make the rotated Chinese Labels fail to show

  1. Install E Origin.

  2. Make graph with Chinese characters labels and rotate the labels

  3. Turn on AA.
    ==> The rotated Chinese characters become corrupted when enable anti-aliasing.
    ==> The problem will happen with Asian characters in Western language Origin, like E/G version with Japanese characters.

Fixed in Origin 2022b.

ORG-24703

Droplines fail to connect with axis line when select a special arrow shape

  1. Make a vertical drop line plot

  2. Open Plot Details dialog, go to drop line tab, change arrow shape to 5th option, click ok
    ==>there are gap between dropline and bottom axis line.

Note: This problem exist when select 5th,6th,7th,11th,12th,13th,14th option in arrow shape combo

ORG-24713

Reference line failed to display when special break exists

  1. New a project, new a graph window, double click Y axis to open dialog.

  2. Go to Reference line tab, type for example 5 in the At Axis Value grid cell, click Apply button.

  3. Go to Breaks tab, activate Horizontal panel, set Number of Breaks as 1.

  4. Set Break From as 0 (scale’s from), Break To as 10 (scale’s to), click Apply.

==> The Reference line disappeared.

ORG-24580

Fill None for Invalid RGB color

  1. wks with 3 columns, set value for these three columns.

  2. set format of col(c) to color and make some row color is missing(invalid RGB)

  3. make 2d scatters plot with col(b)

  4. open PD dialog, go to symbol tab, set symbol color to by point: direct RGB: col(c)

  5. click OK
    ==> the invalid RGB is black color in the plot, which should be fill None.

Fixed in Origin 2022b.

ORG-24743

Pie Map Causes Origin Crash with 18 More Columns

Make Pie Map Chart with 20 columns or more, Origin would crash.

ORG-22583

Copy paste text with backslash lost conversion

Copy path:\\fs1\shared\test and past into Graph window as text label.

==> It became path:\fs1\shared\test

Fixed in Origin 2022b

ORG-24780

Horizontal/Vertical line added by addline x-function Failed to show at specified position after the graph is zoomed in.

E.g. For a graph with x range from 0 to 1,000,000, use script addline type:=0 value:=500 to add a vertical line object at x=500.

Use Scale in tool to zoom in the graph.

==> The line isn’t at x=500

Fixed in Origin 2022b.

ORG-24657

Sample Project could not show label at last point for some plot

  1. open the plot Multi-Panel Graphs - Multiple Layers with Line Plot from Learning Center

  2. select plot in layer 3, select show label in MT

  3. open PD, go to label tab, select Show at specified points only, fill edit box with 0==> not all plot show label for last point

No such issue if you plot a new line plots. This graph is saved from sample project, no such issue in Origin 2021b.

If I enable last point label in Origin 2021b, and open in 2022, some labels are missing.

Fixed in Origin2022b.

ORG-24737

3D surface with transparency crashes in VMware

Repeat the following steps in VMware:

  1. New a matrix and Import"3D Surface & Contour.dat" file in Sample folder.

  2. Make a 3D colormap surface and editing Transparency at Surface tab in Plot Detail dialog
    ==>Origin was crashed

 

Note:

  1. No this problem if not in VMware.

  2. In some VMware, after setting transparency, 3D surface contour lines fail be clipped correctly.
    Let it go for now.